problem when running gazebo

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

problem when running gazebo

zhangqun
Dear all,

after struggling in making the gazebo, i finally succeeded. but
unfortunately met another problem when I run it by

_____________________________________________________________
gazebo /usr/local/share/gazebo/worlds/pioneer2dx.world

Gazebo multi-robot simulator, version 0.9.0

Part of the Player/Stage Project [http://playerstage.sourceforge.net].
Copyright (C) 2003 Nate Koenig, Andrew Howard, and contributors.
Released under the GNU General Public License.

[/home/zhangqun/gazebo/server/GazeboConfig.cc:103]
  Gazebo Path[/usr/local/share/gazebo]
[/home/zhangqun/gazebo/server/GazeboConfig.cc:115]
  Ogre Path[/usr/local/lib/OGRE]
Error Loading Gazebo
/home/zhangqun/gazebo/server/Simulator.cc:235 : Exception: Failed to load
the World
/home/zhangqun/gazebo/server/World.cc:207 : Exception: Unable to create
physics engine

deleting /tmp/gazebo-zhangqun-0/graphics3d.default
Segmentation fault
______________________________________________________________

and a window pops out and quickly disappears. i searched a lot about this
error but nothing solved. i also list the gdb results below and
configuration in my case.


Ubuntu 9.10
player 3.0
gazebo svn
ode 0.11.1
ogre 1.6.3
graphics card ATI 3470 with proprietary FGLRX driver (works well with
rendering)

______________________________________________________________
/usr/share/gazebo/worlds$ gdb gazebo
GNU gdb (GDB) 7.0-ubuntu
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html
>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/local/bin/gazebo...done.
(gdb) run pioneer2dx.world
Starting program: /usr/local/bin/gazebo pioneer2dx.world
[Thread debugging using libthread_db enabled]
Gazebo multi-robot simulator, version 0.9.0

Part of the Player/Stage Project [http://playerstage.sourceforge.net].
Copyright (C) 2003 Nate Koenig, Andrew Howard, and contributors.
Released under the GNU General Public License.

[/home/zhangqun/gazebo/server/GazeboConfig.cc:103]
  Gazebo Path[/usr/local/share/gazebo]
[/home/zhangqun/gazebo/server/GazeboConfig.cc:115]
  Ogre Path[/usr/local/lib/OGRE]
directory [/tmp/gazebo-zhangqun-0] already exists (previous crash?)
but the owner gazebo server (pid=9218) is not running.
deleting the old information of the directory [/tmp/gazebo-zhangqun-0]
Error Loading Gazebo
/home/zhangqun/gazebo/server/Simulator.cc:235 : Exception: Failed to load
the World
/home/zhangqun/gazebo/server/World.cc:207 : Exception: Unable to create
physics engine



deleting /tmp/gazebo-zhangqun-0/graphics3d.default

Program received signal SIGSEGV, Segmentation fault.
do_lookup_x (new_hash=<value optimized out>, old_hash=0xbffff044,
    ref=0x351b18, result=0xbffff038, scope=0xdd37cc, i=3, flags=1, skip=0x0)
    at do-lookup.h:180
180    do-lookup.h: No such file or directory.
    in do-lookup.h
(gdb) bt
#0  do_lookup_x (new_hash=<value optimized out>, old_hash=0xbffff044,
    ref=0x351b18, result=0xbffff038, scope=0xdd37cc, i=3, flags=1, skip=0x0)
    at do-lookup.h:180
#1  0x00dc0009 in _dl_lookup_symbol_x (undef_name=<value optimized out>,
    undef_map=<value optimized out>, ref=0xbffff080,
symbol_scope=0xb7fe3a28,
    version=0xb7fd9850, type_class=1, flags=1, skip_map=0x0) at
dl-lookup.c:338
#2  0x00dc4326 in _dl_fixup (l=<value optimized out>,
    reloc_arg=<value optimized out>) at dl-runtime.c:114
#3  0x00dc9fc0 in _dl_runtime_resolve () at
../sysdeps/i386/dl-trampoline.S:37
#4  0x0035ecb8 in gazebo::Iface::Destroy() ()
   from /usr/local/lib/libgazebo.so.0.9.0
#5  0x00361c60 in gazebo::Iface::~Iface() ()
   from /usr/local/lib/libgazebo.so.0.9.0
#6  0x00369074 in gazebo::Graphics3dIface::~Graphics3dIface() ()
   from /usr/local/lib/libgazebo.so.0.9.0
#7  0x002d9ea6 in gazebo::GraphicsIfaceHandler::~GraphicsIfaceHandler() ()
   from /usr/local/lib/libgazebo_server.so.0.9.0
#8  0x002aab65 in gazebo::World::Fini() ()
   from /usr/local/lib/libgazebo_server.so.0.9.0
#9  0x002dfaae in gazebo::Simulator::Fini() ()
   from /usr/local/lib/libgazebo_server.so.0.9.0
#10 0x0804aa27 in main ()
(gdb)

______________________________________________________________

the gazebo window pops up but no response to any operation.

I appreciate if any one can help me get this done.

Zhang Qun
------------------------------------------------------------------------------
This SF.Net email is sponsored by the Verizon Developer Community
Take advantage of Verizon's best-in-class app development support
A streamlined, 14 day to market process makes app distribution fast and easy
Join now and get one step closer to millions of Verizon customers
http://p.sf.net/sfu/verizon-dev2dev 
_______________________________________________
Playerstage-gazebo mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/playerstage-gazebo
Reply | Threaded
Open this post in threaded view
|

Re: problem when running gazebo

John Hsu-2
Hi Zhang,

It looks like your PhysicsFactory failed to initialize a physics engine
instance, and if you are using the world file that came with gazebo, it is
looking for ode.  Can you pose the compile logs for compilation from a clean
checkout?

Thanks,
John

On Sat, Jan 9, 2010 at 4:20 AM, zhangqun <[hidden email]> wrote:

> Dear all,
>
> after struggling in making the gazebo, i finally succeeded. but
> unfortunately met another problem when I run it by
>
> _____________________________________________________________
> gazebo /usr/local/share/gazebo/worlds/pioneer2dx.world
>
> Gazebo multi-robot simulator, version 0.9.0
>
> Part of the Player/Stage Project [http://playerstage.sourceforge.net].
> Copyright (C) 2003 Nate Koenig, Andrew Howard, and contributors.
> Released under the GNU General Public License.
>
> [/home/zhangqun/gazebo/server/GazeboConfig.cc:103]
>  Gazebo Path[/usr/local/share/gazebo]
> [/home/zhangqun/gazebo/server/GazeboConfig.cc:115]
>  Ogre Path[/usr/local/lib/OGRE]
> Error Loading Gazebo
> /home/zhangqun/gazebo/server/Simulator.cc:235 : Exception: Failed to load
> the World
> /home/zhangqun/gazebo/server/World.cc:207 : Exception: Unable to create
> physics engine
>
> deleting /tmp/gazebo-zhangqun-0/graphics3d.default
> Segmentation fault
> ______________________________________________________________
>
> and a window pops out and quickly disappears. i searched a lot about this
> error but nothing solved. i also list the gdb results below and
> configuration in my case.
>
>
> Ubuntu 9.10
> player 3.0
> gazebo svn
> ode 0.11.1
> ogre 1.6.3
> graphics card ATI 3470 with proprietary FGLRX driver (works well with
> rendering)
>
> ______________________________________________________________
> /usr/share/gazebo/worlds$ gdb gazebo
> GNU gdb (GDB) 7.0-ubuntu
> Copyright (C) 2009 Free Software Foundation, Inc.
> License GPLv3+: GNU GPL version 3 or later <
> http://gnu.org/licenses/gpl.html
> >
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
> and "show warranty" for details.
> This GDB was configured as "i486-linux-gnu".
> For bug reporting instructions, please see:
> <http://www.gnu.org/software/gdb/bugs/>...
> Reading symbols from /usr/local/bin/gazebo...done.
> (gdb) run pioneer2dx.world
> Starting program: /usr/local/bin/gazebo pioneer2dx.world
> [Thread debugging using libthread_db enabled]
> Gazebo multi-robot simulator, version 0.9.0
>
> Part of the Player/Stage Project [http://playerstage.sourceforge.net].
> Copyright (C) 2003 Nate Koenig, Andrew Howard, and contributors.
> Released under the GNU General Public License.
>
> [/home/zhangqun/gazebo/server/GazeboConfig.cc:103]
>  Gazebo Path[/usr/local/share/gazebo]
> [/home/zhangqun/gazebo/server/GazeboConfig.cc:115]
>  Ogre Path[/usr/local/lib/OGRE]
> directory [/tmp/gazebo-zhangqun-0] already exists (previous crash?)
> but the owner gazebo server (pid=9218) is not running.
> deleting the old information of the directory [/tmp/gazebo-zhangqun-0]
> Error Loading Gazebo
> /home/zhangqun/gazebo/server/Simulator.cc:235 : Exception: Failed to load
> the World
> /home/zhangqun/gazebo/server/World.cc:207 : Exception: Unable to create
> physics engine
>
>
>
> deleting /tmp/gazebo-zhangqun-0/graphics3d.default
>
> Program received signal SIGSEGV, Segmentation fault.
> do_lookup_x (new_hash=<value optimized out>, old_hash=0xbffff044,
>    ref=0x351b18, result=0xbffff038, scope=0xdd37cc, i=3, flags=1, skip=0x0)
>    at do-lookup.h:180
> 180    do-lookup.h: No such file or directory.
>    in do-lookup.h
> (gdb) bt
> #0  do_lookup_x (new_hash=<value optimized out>, old_hash=0xbffff044,
>    ref=0x351b18, result=0xbffff038, scope=0xdd37cc, i=3, flags=1, skip=0x0)
>    at do-lookup.h:180
> #1  0x00dc0009 in _dl_lookup_symbol_x (undef_name=<value optimized out>,
>    undef_map=<value optimized out>, ref=0xbffff080,
> symbol_scope=0xb7fe3a28,
>    version=0xb7fd9850, type_class=1, flags=1, skip_map=0x0) at
> dl-lookup.c:338
> #2  0x00dc4326 in _dl_fixup (l=<value optimized out>,
>    reloc_arg=<value optimized out>) at dl-runtime.c:114
> #3  0x00dc9fc0 in _dl_runtime_resolve () at
> ../sysdeps/i386/dl-trampoline.S:37
> #4  0x0035ecb8 in gazebo::Iface::Destroy() ()
>   from /usr/local/lib/libgazebo.so.0.9.0
> #5  0x00361c60 in gazebo::Iface::~Iface() ()
>   from /usr/local/lib/libgazebo.so.0.9.0
> #6  0x00369074 in gazebo::Graphics3dIface::~Graphics3dIface() ()
>   from /usr/local/lib/libgazebo.so.0.9.0
> #7  0x002d9ea6 in gazebo::GraphicsIfaceHandler::~GraphicsIfaceHandler() ()
>   from /usr/local/lib/libgazebo_server.so.0.9.0
> #8  0x002aab65 in gazebo::World::Fini() ()
>   from /usr/local/lib/libgazebo_server.so.0.9.0
> #9  0x002dfaae in gazebo::Simulator::Fini() ()
>   from /usr/local/lib/libgazebo_server.so.0.9.0
> #10 0x0804aa27 in main ()
> (gdb)
>
> ______________________________________________________________
>
> the gazebo window pops up but no response to any operation.
>
> I appreciate if any one can help me get this done.
>
> Zhang Qun
>
> ------------------------------------------------------------------------------
> This SF.Net email is sponsored by the Verizon Developer Community
> Take advantage of Verizon's best-in-class app development support
> A streamlined, 14 day to market process makes app distribution fast and
> easy
> Join now and get one step closer to millions of Verizon customers
> http://p.sf.net/sfu/verizon-dev2dev
> _______________________________________________
> Playerstage-gazebo mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/playerstage-gazebo
>
------------------------------------------------------------------------------
Throughout its 18-year history, RSA Conference consistently attracts the
world's best and brightest in the field, creating opportunities for Conference
attendees to learn about information security's most important issues through
interactions with peers, luminaries and emerging and established companies.
http://p.sf.net/sfu/rsaconf-dev2dev
_______________________________________________
Playerstage-gazebo mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/playerstage-gazebo
Reply | Threaded
Open this post in threaded view
|

Re: problem when running gazebo

Qiang
In reply to this post by zhangqun
Hi, Zhang qun

I am meeting the same problem with you.
I install on my computer(laptop) with wubi9.0(similar with ubuntu 9.10),
my graphic card is ATI RADEON HD3450.
ogre 1.6.5
ode. 0.11.1
gazebo0.10.0

you can find the debug report below, but I did not fix it now, and I want to continue fix it, do you have some advice/
http://old.nabble.com/X_CreateGC%3A-BadDrawable-%28invalid-Pixmap-or-Window-parameter%29-0x4800002-td27840428.html#a27852458

Qiang Li

zhangqun wrote
Dear all,

after struggling in making the gazebo, i finally succeeded. but
unfortunately met another problem when I run it by

_____________________________________________________________
gazebo /usr/local/share/gazebo/worlds/pioneer2dx.world

Gazebo multi-robot simulator, version 0.9.0

Part of the Player/Stage Project [http://playerstage.sourceforge.net].
Copyright (C) 2003 Nate Koenig, Andrew Howard, and contributors.
Released under the GNU General Public License.

[/home/zhangqun/gazebo/server/GazeboConfig.cc:103]
  Gazebo Path[/usr/local/share/gazebo]
[/home/zhangqun/gazebo/server/GazeboConfig.cc:115]
  Ogre Path[/usr/local/lib/OGRE]
Error Loading Gazebo
/home/zhangqun/gazebo/server/Simulator.cc:235 : Exception: Failed to load
the World
/home/zhangqun/gazebo/server/World.cc:207 : Exception: Unable to create
physics engine

deleting /tmp/gazebo-zhangqun-0/graphics3d.default
Segmentation fault
______________________________________________________________

and a window pops out and quickly disappears. i searched a lot about this
error but nothing solved. i also list the gdb results below and
configuration in my case.


Ubuntu 9.10
player 3.0
gazebo svn
ode 0.11.1
ogre 1.6.3
graphics card ATI 3470 with proprietary FGLRX driver (works well with
rendering)

______________________________________________________________
/usr/share/gazebo/worlds$ gdb gazebo
GNU gdb (GDB) 7.0-ubuntu
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html
>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/local/bin/gazebo...done.
(gdb) run pioneer2dx.world
Starting program: /usr/local/bin/gazebo pioneer2dx.world
[Thread debugging using libthread_db enabled]
Gazebo multi-robot simulator, version 0.9.0

Part of the Player/Stage Project [http://playerstage.sourceforge.net].
Copyright (C) 2003 Nate Koenig, Andrew Howard, and contributors.
Released under the GNU General Public License.

[/home/zhangqun/gazebo/server/GazeboConfig.cc:103]
  Gazebo Path[/usr/local/share/gazebo]
[/home/zhangqun/gazebo/server/GazeboConfig.cc:115]
  Ogre Path[/usr/local/lib/OGRE]
directory [/tmp/gazebo-zhangqun-0] already exists (previous crash?)
but the owner gazebo server (pid=9218) is not running.
deleting the old information of the directory [/tmp/gazebo-zhangqun-0]
Error Loading Gazebo
/home/zhangqun/gazebo/server/Simulator.cc:235 : Exception: Failed to load
the World
/home/zhangqun/gazebo/server/World.cc:207 : Exception: Unable to create
physics engine



deleting /tmp/gazebo-zhangqun-0/graphics3d.default

Program received signal SIGSEGV, Segmentation fault.
do_lookup_x (new_hash=<value optimized out>, old_hash=0xbffff044,
    ref=0x351b18, result=0xbffff038, scope=0xdd37cc, i=3, flags=1, skip=0x0)
    at do-lookup.h:180
180    do-lookup.h: No such file or directory.
    in do-lookup.h
(gdb) bt
#0  do_lookup_x (new_hash=<value optimized out>, old_hash=0xbffff044,
    ref=0x351b18, result=0xbffff038, scope=0xdd37cc, i=3, flags=1, skip=0x0)
    at do-lookup.h:180
#1  0x00dc0009 in _dl_lookup_symbol_x (undef_name=<value optimized out>,
    undef_map=<value optimized out>, ref=0xbffff080,
symbol_scope=0xb7fe3a28,
    version=0xb7fd9850, type_class=1, flags=1, skip_map=0x0) at
dl-lookup.c:338
#2  0x00dc4326 in _dl_fixup (l=<value optimized out>,
    reloc_arg=<value optimized out>) at dl-runtime.c:114
#3  0x00dc9fc0 in _dl_runtime_resolve () at
../sysdeps/i386/dl-trampoline.S:37
#4  0x0035ecb8 in gazebo::Iface::Destroy() ()
   from /usr/local/lib/libgazebo.so.0.9.0
#5  0x00361c60 in gazebo::Iface::~Iface() ()
   from /usr/local/lib/libgazebo.so.0.9.0
#6  0x00369074 in gazebo::Graphics3dIface::~Graphics3dIface() ()
   from /usr/local/lib/libgazebo.so.0.9.0
#7  0x002d9ea6 in gazebo::GraphicsIfaceHandler::~GraphicsIfaceHandler() ()
   from /usr/local/lib/libgazebo_server.so.0.9.0
#8  0x002aab65 in gazebo::World::Fini() ()
   from /usr/local/lib/libgazebo_server.so.0.9.0
#9  0x002dfaae in gazebo::Simulator::Fini() ()
   from /usr/local/lib/libgazebo_server.so.0.9.0
#10 0x0804aa27 in main ()
(gdb)

______________________________________________________________

the gazebo window pops up but no response to any operation.

I appreciate if any one can help me get this done.

Zhang Qun
------------------------------------------------------------------------------
This SF.Net email is sponsored by the Verizon Developer Community
Take advantage of Verizon's best-in-class app development support
A streamlined, 14 day to market process makes app distribution fast and easy
Join now and get one step closer to millions of Verizon customers
http://p.sf.net/sfu/verizon-dev2dev 
_______________________________________________
Playerstage-gazebo mailing list
Playerstage-gazebo@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/playerstage-gazebo