libgazebo_player is present but not found

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

libgazebo_player is present but not found

ulle
This post has NOT been accepted by the mailing list yet.
I have been using player/stage together with control code in c++ for a while and want to upgrade to player/gazebo. To get started I have followed the guide below. http://gazebosim.org/user_guide/startedinterfacesplayer.html

When I run "gazebo pioneer2dx.world" gazebo starts up fine, but when I run "player gazebo.cfg" I get the following error messages:

error   : Failed to load plugin libgazebo_player.
error   : libtool reports error: file not found
error   : plugin search path: /home/ulrik/Work/thirdparty/gazebo_source/test:.:/usr/local/lib/
error   : failed to load plugin: libgazebo_player
error   : failed to parse config file gazebo.cfg driver blocks

Both player (version 3.1.0) and gazebo (version 1.9) are installed in /usr/local and libgazebo_player.so is located in /usr/local/lib. LD_LIBRARY_PATH is set to /usr/local/lib. I installed player before gazebo and gazebo found player when installed. (No warnings or errors when running cmake.)

Any ideas what I am doing wrong?
Thanks, Ulrik