libgazebo gets stuck when connecting to the simulator

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

libgazebo gets stuck when connecting to the simulator

Luis Manso
Hi,

I'm using libgazebo to connect to the simulator. I would like to run two
separate clients, but the second client I run always gets stuck.

Using versions pre-0.9 everything worked just fine using the following line
in both clients:
  client->ConnectWait(0, 0);

Since I switched to the SVN version it does not work anymore. According to
the documentation, I understand that the first client must connect using:
  client->ConnectWait(0, GZ_CLIENT_ID_USER_FIRST+0);
and the second, using:
client->ConnectWait(0, GZ_CLIENT_ID_USER_FIRST+1);

The problem is that it does not work neither in the SVN or 0.9 version. The
second client I run always get stuck in the corresponding line. I tried
using 0.9 and the last SVN revision.

Some information:

void Client::ConnectWait(int serverId, int clientId) stops in line 180:
              simulationIface.Close();

void SimulationIface::Close() stops in line 102:
    this->goAckThread->join();       //wait till it's stopped

It seems that the thread does'nt want to be stopped :) As I don't know much
about boost threads, I don't know how to solve the problem.

Regards

Luis
------------------------------------------------------------------------------
Start uncovering the many advantages of virtual appliances
and start using them to simplify application deployment and
accelerate your shift to cloud computing.
http://p.sf.net/sfu/novell-sfdev2dev
_______________________________________________
Playerstage-gazebo mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/playerstage-gazebo