Problem running gazebo 0.10.0

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problem running gazebo 0.10.0

dshih
$ uname -a
Linux samurai 2.6.34-ARCH #1 SMP PREEMPT Mon Jul 5 22:12:11 CEST 2010 x86_64 Intel(R) Core(TM)2 Duo CPU E7200 @ 2.53GHz GenuineIntel GNU/Linux

I have installed all the dependencies of gazebo 0.10.0 (except the optional dependency websim), then compiled and installed gazebo.

Player v.3.0.2
libxml2-2.7.7-1
bullet 2.76-2
ode-0.11.1-1
ogre 1.7.1-2


When I try running gazebo while specifying a world file...
$ gazebo -grnp /usr/local/share/gazebo/worlds/epuck.world
Gazebo multi-robot simulator, version 0.10.0

Part of the Player/Stage Project [http://playerstage.sourceforge.net].
Copyright (C) 2003 Nate Koenig, Andrew Howard, and contributors.
Released under the GNU General Public License.

/usr/local/share/gazebo/worlds/epuck.world:1: parser error : Document is empty

^
/usr/local/share/gazebo/worlds/epuck.world:1: parser error : Start tag expected, '<' not found

^
Error Loading Gazebo
/home/katana/builds/robot/gazebo-0.10.0/server/Simulator.cc:151 : Exception: The XML config file can not be loaded, please make sure is a correct file
/home/katana/builds/robot/gazebo-0.10.0/server/XMLConfig.cc:129 : Exception: Unable to parse xml file: /usr/local/share/gazebo/worlds/epuck.world

The epuck.world file does not seem to be empty when I opened it with vim...
I tried other world files, and I got the same error.