Gazebo 0.9.0 err. Not loading world files

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Gazebo 0.9.0 err. Not loading world files

gauthampdas
Hi,

I am using Ubuntu Lucid Lynx (10.04).
Have

Player 2.13
Stage 2.1.1
ODE 0.11.1
OGRE 1.6.4
Bullet 2.77
Gazebo 0.9.0

As I have to use player 2, I am sticking with gazebo 0.9.0 instead of going
for 0.10.0

Except ODE all others have been installed from source. I was not able to
make gazebo run. I am getting error during world file loading. Here is the
gdb

Here is the terminal logs.

gpdas@Gautham-P-Das:/usr/local/lib/python2.4/site-packages$ gdb gazebo
GNU gdb (GDB) 7.1-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html
>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/local/bin/gazebo...(no debugging symbols
found)...done.
(gdb) r /usr/local/share/gazebo/worlds/pioneer2at.world
Starting program: /usr/local/bin/gazebo
/usr/local/share/gazebo/worlds/pioneer2at.world
[Thread debugging using libthread_db enabled]
Gazebo multi-robot simulator, version 0.9.0

Part of the Player/Stage Project [http://playerstage.sourceforge.net].
Copyright (C) 2003 Nate Koenig, Andrew Howard, and contributors.
Released under the GNU General Public License.

/usr/local/share/gazebo/worlds/models/pioneer2at.model:18: namespace error :
Namespace prefix controller on differential_position2d is not defined
<controller:differential_position2d name="controller1">
                                                      ^
/usr/local/share/gazebo/worlds/models/pioneer2at.model:24: namespace error :
Namespace prefix interface on position is not defined
  <interface:position name="position_iface_0"/>
                                             ^
[/home/gpdas/Downloads/gazebo-0.9.0/server/GazeboConfig.cc:103]
  Gazebo Path[/usr/local/share/gazebo]
[/home/gpdas/Downloads/gazebo-0.9.0/server/GazeboConfig.cc:115]
  Ogre Path[/usr/local/lib/OGRE]
creating /tmp/gazebo-gpdas-0
directory [/tmp/gazebo-gpdas-0] already exists (previous crash?)
but the owner gazebo server (pid=4803) is not running.
deleting the old information of the directory [/tmp/gazebo-gpdas-0]
creating /tmp/gazebo-gpdas-0/simulation.default 112 33842332
creating /tmp/gazebo-gpdas-0/factory.default 112 410188
creating /tmp/gazebo-gpdas-0/graphics3d.default 112 1630256

Program received signal SIGSEGV, Segmentation fault.
0xb67ed6d5 in std::string::assign(std::string const&) () from
/usr/lib/libstdc++.so.6
(gdb) bt
#0  0xb67ed6d5 in std::string::assign(std::string const&) () from
/usr/lib/libstdc++.so.6
#1  0xb6c23313 in gazebo::Geom::Load(gazebo::XMLConfigNode*) () from
/usr/local/lib/libgazebo_server.so.0.9.0
#2  0xb6c198cd in gazebo::Body::LoadGeom(gazebo::XMLConfigNode*) () from
/usr/local/lib/libgazebo_server.so.0.9.0
#3  0xb6c1a207 in gazebo::Body::Load(gazebo::XMLConfigNode*) () from
/usr/local/lib/libgazebo_server.so.0.9.0
#4  0xb6c9d601 in gazebo::Model::LoadBody(gazebo::XMLConfigNode*) () from
/usr/local/lib/libgazebo_server.so.0.9.0
#5  0xb6c9e64e in gazebo::Model::LoadPhysical(gazebo::XMLConfigNode*) ()
from /usr/local/lib/libgazebo_server.so.0.9.0
#6  0xb6ca3197 in gazebo::Model::Load(gazebo::XMLConfigNode*, bool) () from
/usr/local/lib/libgazebo_server.so.0.9.0
#7  0xb6c86e6f in gazebo::World::LoadModel(gazebo::XMLConfigNode*,
gazebo::Model*, bool) () from /usr/local/lib/libgazebo_server.so.0.9.0
#8  0xb6c8722e in gazebo::World::LoadEntities(gazebo::XMLConfigNode*,
gazebo::Model*, bool) () from /usr/local/lib/libgazebo_server.so.0.9.0
#9  0xb6c871f2 in gazebo::World::LoadEntities(gazebo::XMLConfigNode*,
gazebo::Model*, bool) () from /usr/local/lib/libgazebo_server.so.0.9.0
#10 0xb6c87959 in gazebo::World::Load(gazebo::XMLConfigNode*, unsigned int)
() from /usr/local/lib/libgazebo_server.so.0.9.0
#11 0xb6cadfa4 in gazebo::Simulator::Load(std::string const&, unsigned int)
() from /usr/local/lib/libgazebo_server.so.0.9.0
#12 0x0804a230 in main ()


I tried with all sample files and all were failing with the same error.


Thanks & Regards,

Gautham P. Das

* University of Ulster,
*
------------------------------------------------------------------------------
Gaining the trust of online customers is vital for the success of any company
that requires sensitive data to be transmitted over the Web.   Learn how to
best implement a security strategy that keeps consumers' information secure
and instills the confidence they need to proceed with transactions.
http://p.sf.net/sfu/oracle-sfdevnl 
_______________________________________________
Playerstage-gazebo mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/playerstage-gazebo